Inhibit a spurious warning on GCC 4.0.1