[util] Make mtools check detect new versions
authorStefan Hajnoczi <stefanha@gmail.com>
Wed, 14 Oct 2009 07:11:04 +0000 (08:11 +0100)
committerMarty Connor <mdc@etherboot.org>
Thu, 15 Oct 2009 18:54:30 +0000 (14:54 -0400)
The mtools version check does not handle GNU mtools 4.0.10.  This commit
makes the pattern more general so it matches older mtools as well as the
newer "mtools (GNU mtools) 4.0.10" string.

Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
Signed-off-by: Marty Connor <mdc@etherboot.org>
src/util/genliso
src/util/gensdsk

index aa51785..1f1c116 100755 (executable)
@@ -15,7 +15,7 @@ case $# in
 esac
 
 case "`mtools -V`" in
-Mtools\ version\ 3.9.9*|Mtools\ version\ 3.9.1[0-9]*|Mtools\ version\ 4.*)
+Mtools\ version\ 3.9.9*|Mtools\ version\ 3.9.1[0-9]*|[mM]tools\ *\ [4-9].*)
        ;;
 *)
        echo Mtools version 3.9.9 or later is required
index 787dfa2..a866158 100644 (file)
@@ -15,7 +15,7 @@ case $# in
        ;;
 esac
 case "`mtools -V`" in
-Mtools\ version\ 3.9.9*|Mtools\ version\ 3.9.1[0-9]*|Mtools\ version\ 4.*)
+Mtools\ version\ 3.9.9*|Mtools\ version\ 3.9.1[0-9]*|[mM]tools\ *\ [4-9].*)
        ;;
 *)
        echo Mtools version 3.9.9 or later is required