[build] Inhibit "skipping incompatible" message from ld
authorMichael Brown <mcb30@ipxe.org>
Thu, 27 May 2010 08:42:53 +0000 (09:42 +0100)
committerStefan Hajnoczi <stefanha@gmail.com>
Wed, 7 Jul 2010 19:14:37 +0000 (20:14 +0100)
On 64-bit systems with both 32-bit and 64-bit libraries installed, ld
tends to generate noisy "skipping incompatible /usr/lib/libxxx.so"
messages when building elf2efi.c.

Fix by passing --no-warn-search-mismatch to ld.

Signed-off-by: Michael Brown <mcb30@ipxe.org>
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
src/Makefile.housekeeping

index 0de3fc2..7aadadf 100644 (file)
@@ -876,7 +876,8 @@ CLEANUP += $(ZBIN)
 ELF2EFI_CFLAGS := -I$(BINUTILS_DIR)/include -I$(BFD_DIR)/include \
                   -I$(ZLIB_DIR)/include -idirafter include \
                   -L$(BINUTILS_DIR)/lib -L$(BFD_DIR)/lib \
-                  -L$(ZLIB_DIR)/lib -lbfd -liberty -lz
+                  -L$(ZLIB_DIR)/lib -lbfd -liberty -lz \
+                  -Wl,--no-warn-search-mismatch
 
 $(ELF2EFI32) : util/elf2efi.c $(MAKEDEPS)
        $(QM)$(ECHO) "  [HOSTCC] $@"