Added a test for NewBuild argument if this is the second time through the setup ...
authorlhauch <lhauch@de2fecce-e211-0410-80a6-f3fac2684e05>
Thu, 25 Oct 2007 18:53:37 +0000 (18:53 +0000)
committerlhauch <lhauch@de2fecce-e211-0410-80a6-f3fac2684e05>
Thu, 25 Oct 2007 18:53:37 +0000 (18:53 +0000)
git-svn-id: https://edk2.tianocore.org/svn/edk2/trunk@4218 de2fecce-e211-0410-80a6-f3fac2684e05

edk2/edksetup.bat

index 9bb95a5..dbc6312 100644 (file)
@@ -55,11 +55,11 @@ goto check_vc
 @REM platform emulation environment.\r
 if defined VCINSTALLDIR goto check_cygwin\r
 if defined VS71COMNTOOLS (\r
- @REM Use Visual Studio .NET 2003 if it is installed\r
- call "%VS71COMNTOOLS%\vsvars32.bat"\r
 @REM Use Visual Studio .NET 2003 if it is installed\r
 call "%VS71COMNTOOLS%\vsvars32.bat"\r
 ) else if defined VS80COMNTOOLS (\r
- @REM Use Visual Studio 2005 iff Visual Studio .NET 2003 is not installed.\r
- call "%VS80COMNTOOLS%\vsvars32.bat"\r
 @REM Use Visual Studio 2005 iff Visual Studio .NET 2003 is not installed.\r
 call "%VS80COMNTOOLS%\vsvars32.bat"\r
 ) else (\r
   echo.\r
   echo !!! WARNING !!!! Cannot find Visual Studio !!!\r
@@ -68,6 +68,7 @@ if defined VS71COMNTOOLS (
 goto check_new_build\r
 \r
 :check_cygwin\r
+@if /I "%1"=="NewBuild" goto NewBuild\r
 if defined CYGWIN_HOME goto check_java\r
 if exist c:\cygwin (\r
   set CYGWIN_HOME=c:\cygwin\r
@@ -293,6 +294,7 @@ echo.
 @goto end\r
 \r
 :NewBuild\r
+echo in NewBuild\r
 @IF NOT EXIST "BaseTools\toolsetup.bat" goto AntBuild\r
 if not defined EDK_TOOLS_PATH set EDK_TOOLS_PATH=%WORKSPACE%\BaseTools\r
 @call BaseTools\toolsetup.bat\r