Update ChangeLog.txt to log remove PeCoffLoader library class from MdeModulePkg.
authorlgao4 <lgao4@de2fecce-e211-0410-80a6-f3fac2684e05>
Fri, 28 Sep 2007 09:17:15 +0000 (09:17 +0000)
committerlgao4 <lgao4@de2fecce-e211-0410-80a6-f3fac2684e05>
Fri, 28 Sep 2007 09:17:15 +0000 (09:17 +0000)
git-svn-id: https://edk2.tianocore.org/svn/edk2/trunk@3971 de2fecce-e211-0410-80a6-f3fac2684e05

edk2/MdeModulePkg/ChangeLog.txt

index d72f259..dbad47f 100644 (file)
@@ -146,4 +146,18 @@ EDK_3773:  Non-Compatible: qwang12
                   use gEfiFirmwareVolume2ProtocolGuid.\r
                3) The gEfiFirmwareVolumeProtocolGuid in [Depex] section of INF file should updated.\r
                   And the package dependency should also be changed if needed due to this protocol\r
-                  GUID change.
\ No newline at end of file
+                  GUID change.\r
+\r
+==========================================================================================\r
+EDK_3967:  Non-Compatible: lgao4\r
+\r
+         Class_Library:  Remove PeCoffLoader library class and its instances.\r
+\r
+               Code Change :\r
+               1) Remove MdeModulePkg/Include/Library/PeCoffLoaderLib.h\r
+               2) Remove MdeModulePkg/Library/DxePeCoffLoaderFromHobLib and PeiDxePeCoffLoaderLib instance\r
+               3) Modify PeiCore, DxeIpl and DxeCore to use PeCoffLib in place of PeCoffLoaderLib.\r
+\r
+               Possible Impacts:\r
+               1) All modules don't use PeCoffloader library class any longer to load PeImage. \r
+                  If necessary, they should use PeCoffLib of MdePkg to load PeImage.\r