Fix the Saxon8 instructions.
authorbbahnsen <bbahnsen@de2fecce-e211-0410-80a6-f3fac2684e05>
Tue, 9 May 2006 23:46:42 +0000 (23:46 +0000)
committerbbahnsen <bbahnsen@de2fecce-e211-0410-80a6-f3fac2684e05>
Tue, 9 May 2006 23:46:42 +0000 (23:46 +0000)
git-svn-id: https://edk2.tianocore.org/svn/edk2/trunk@117 de2fecce-e211-0410-80a6-f3fac2684e05

www/installation.html

index d5c03ab..afc7b04 100644 (file)
@@ -63,10 +63,11 @@ JDK</td>
     </tr>\r
     <tr>\r
       <td style="text-align: center; font-weight: bold;">Saxon-B</td>\r
-      <td style="text-align: center; font-weight: bold;">8.7.1 for Java<br>\r
+      <td style="text-align: center; font-weight: bold;">8.1.1 for Java<br>\r
       </td>\r
       <td style="text-align: center;"><a\r
- href="http://saxon.sourceforge.net/#F8.7.1B">http://saxon.sourceforge.net/#F8.7.1B</a></td>\r
+ href="http://prdownloads.sourceforge.net/saxon/saxonb8-1-1.zip">http://prdownloads.sourceforge.net/saxon/saxonb8-1-1.zip<br>\r
+      </a></td>\r
     </tr>\r
     <tr>\r
       <td style="text-align: center; font-weight: bold;">XMLBeans</td>\r
@@ -199,8 +200,9 @@ before attempting to build:<br>
 <pre>set XMLBEANS_HOME=C:\&lt;full path to where xmlbeans was installed&gt;</pre>\r
 The saxon8.jar file should be <span style="font-weight: bold;">copied </span>to\r
 the %XMLBEANS_HOME%\lib\r
-directory.<br>\r
-<br>\r
+directory. Do not download a later version of saxon 8. You will get the\r
+following error message if you do:<br>\r
+<pre>build.xml:45: java.lang.RuntimeException:&nbsp; Trying XBeans path engine... Trying XQRL... Trying Saxon... FAILED on declare namespace sans='http://www.TianoCore.org/2006/Edk2.0'; $this/sans:FrameworkPlatformDescription/sans:Flash/sans:FvImages/sans:FvImage[@Type='ValidImageNames']/sans:FvImageNames</pre>\r
 The Ant and XMLBean tools are required to be in the path.<br>\r
 <pre>set PATH=%PATH%;%ANT_HOME%\bin;%XMLBEANS_HOME%\bin<br></pre>\r
 <h3>Cygwin</h3>\r