Moved some content out of top level of the schema into local sections.
[people/mcb30/basetools.git] / README.txt
1 \r
2 This file decribes how to build the BaseTools project.\r
3 \r
4 === Windows/Visual Studio Notes ===\r
5 \r
6 To build the BaseTools, you should run the standard vsvars32.bat script.\r
7 \r
8 In addition to this, you should set the following environment variables:\r
9 \r
10  * EDK_TOOLS_PATH - Path to the BaseTools sub directory under the edk2 tree\r
11  * BASE_TOOLS_PATH - The directory where the BaseTools source is located.\r
12    (It is the same directory where this README.txt is located.)\r
13  * PYTHON_FREEZER_PATH - Path to where the python freezer tool is installed\r
14 \r
15 After this, you can run the toolsetup.bat file, which is in the same\r
16 directory as this file.  It should setup the remainder of the environment,\r
17 and build the tools if necessary.\r
18 \r
19 Please also refer to the 'BuildNotes.txt' file for more information on\r
20 building under Windows.\r
21 \r
22 === Unix-like operating systems ===\r
23 \r
24 To build on Unix-like operating systems, you only need to type 'make' in\r
25 the base directory of the project.\r
26 \r
27 === Ubuntu Notes ===\r
28 \r
29 On Ubuntu, the following command should install all the necessary build\r
30 packages to build all the C BaseTools:\r
31 \r
32   sudo apt-get install build-essentials uuid-dev\r
33 \r
34 === Python antlr3 module ===\r
35 \r
36 Installation of the anltr3 python module is required to use the Python\r
37 BaseTools code.  This module can be installed from:\r
38   http://www.antlr.org/download/Python/\r
39 \r
40 You make use of the python easy_install command to install the antlr3 module.\r
41 To 'install' the easy_install python command:\r
42   On Ubuntu, install the python-setuptools package:\r
43     sudo apt-get install python-setuptools\r
44   Or, refer to this web page:\r
45     http://wiki.python.org/moin/EasyInstall\r
46 \r
47 After you have easy_install available, you can use it to install the\r
48 antlr3 module (You may need to check http://www.antlr.org/download/Python\r
49 to see if there is a newer version):\r
50   sudo easy_install \\r
51     http://www.antlr.org/download/Python/antlr_python_runtime-3.0.1-py2.5.egg\r
52 \r