[MLX4] The following patch solves a problem on some machines where IbInstaller.dll...
[mirror/winof/.git] / hw / mlx4 / kernel / hca / mlx4_hca.inf
index d832c0b..9cd1530 100644 (file)
@@ -16,11 +16,11 @@ CatalogFile=mlx4_hca.cat
 ;*****************************************\r
 \r
 [DestinationDirs]\r
-DefaultDestDir = 12\r
-Wdf_CoInstaller_CopyFiles = 11\r
-ClassCopyFiles = 11\r
-MLX4HCA.UMCopyFiles = 11\r
-MLX4HCA.WOW64CopyFiles = 16425\r
+DefaultDestDir = %DIRID_DRIVERS%\r
+ClassCopyFiles = %DIRID_SYSTEM%\r
+MLX4HCA.UMCopyFiles = %DIRID_SYSTEM%\r
+MLX4HCA.WOW64CopyFiles = %DIRID_SYSTEM_X86%\r
+;Wdf_CoInstaller_CopyFiles = %DIRID_SYSTEM%\r
 \r
 ;*****************************************\r
 ; Class Install section\r
@@ -54,14 +54,14 @@ HKLM,"System\CurrentControlSet\Control\CoDeviceInstallers", \
 1=%DiskId%,,,""\r
 \r
 [SourceDisksFiles.x86]\r
-IbInstaller.dll=1\r
+IbInstaller.dll = 1,,\r
 mlx4_hca.sys = 1,,\r
 mlx4u.dll = 1,,\r
 mlx4ud.dll = 1,,\r
 ;wdfcoinstaller01005.dll = 1,,\r
 \r
 [SourceDisksFiles.amd64]\r
-IbInstaller.dll=1\r
+IbInstaller.dll = 1,,\r
 mlx4_hca.sys = 1,,\r
 mlx4u.dll = 1,,\r
 mlx4ud.dll = 1,,\r
@@ -70,7 +70,7 @@ mlx4u32d.dll = 1,,
 ;wdfcoinstaller01005.dll = 1,,\r
 \r
 [SourceDisksFiles.ia64]\r
-IbInstaller.dll=1\r
+IbInstaller.dll = 1,,\r
 mlx4_hca.sys = 1,,\r
 mlx4u.dll = 1,,\r
 mlx4ud.dll = 1,,\r
@@ -220,3 +220,6 @@ SERVICE_DEMAND_START   = 3
 SERVICE_ERROR_NORMAL   = 1\r
 REG_DWORD              = 0x00010001\r
 REG_MULTI_SZ_APPEND    = 0x00010008\r
+DIRID_SYSTEM           = 11\r
+DIRID_DRIVERS          = 12\r
+DIRID_SYSTEM_X86       = 16425\r