Allow to compile with modern gcc-4.x compiler, which make some sophisticated