Applied fix for sparse warning to 2.6.31.4 too.
authorbvassche <bvassche@d57e44dd-8a1f-0410-8b47-8ef2f437770f>
Wed, 14 Oct 2009 07:07:53 +0000 (07:07 +0000)
committerbvassche <bvassche@d57e44dd-8a1f-0410-8b47-8ef2f437770f>
Wed, 14 Oct 2009 07:07:53 +0000 (07:07 +0000)
git-svn-id: https://scst.svn.sourceforge.net/svnroot/scst/trunk@1209 d57e44dd-8a1f-0410-8b47-8ef2f437770f

scripts/run-regression-tests

index e5516d1..3d757a3 100755 (executable)
@@ -119,7 +119,7 @@ See also http://lkml.org/lkml/2009/4/5/120
  #define likely_notrace(x)     __builtin_expect(!!(x), 1)
 EOF
     fi
-    if [ "$1" = "2.6.31" -o "$1" = "2.6.31.1" -o "$1" = "2.6.31.2" -o "$1" = "2.6.31.3" ]
+    if [ "$1" = "2.6.31" -o "$1" = "2.6.31.1" -o "$1" = "2.6.31.2" -o "$1" = "2.6.31.3" -o "$1" = "2.6.31.4" ]
     then
       cd "../linux-$1" || return $?
       patch -f -s -p1 <<'EOF'