The patch below fixes several recently introduced sparse warnings and
authorvlnb <vlnb@d57e44dd-8a1f-0410-8b47-8ef2f437770f>
Thu, 13 Aug 2009 17:34:32 +0000 (17:34 +0000)
committervlnb <vlnb@d57e44dd-8a1f-0410-8b47-8ef2f437770f>
Thu, 13 Aug 2009 17:34:32 +0000 (17:34 +0000)
commit88edc52163475a96966d2de4e6332491ae85330d
tree05f7935e25e45971c44633a86be90b5373ba71d0
parent1e635120f41112ea514ea5127834c68f5ac8d683
The patch below fixes several recently introduced sparse warnings and
errors. The patch below has been tested by verifying the output of the following commands:
  scripts/run-regression-tests 2.6.29
  scripts/run-regression-tests 2.6.30.4

Signed-off-by: Bart Van Assche <bart.vanassche@gmail.com>
Committed with some minor changes/additions.

git-svn-id: https://scst.svn.sourceforge.net/svnroot/scst/trunk@1044 d57e44dd-8a1f-0410-8b47-8ef2f437770f
scst/kernel/scst_exec_req_fifo-2.6.30.patch
scst/src/scst_lib.c