[util] Make mtools test for .liso images more flexible
authorMarty Connor <mdc@etherboot.org>
Tue, 1 Jul 2008 13:04:14 +0000 (09:04 -0400)
committerMarty Connor <mdc@etherboot.org>
Tue, 1 Jul 2008 13:04:14 +0000 (09:04 -0400)
Author: Stefan Hajnoczi <stefanha@gmail.com>
Date:   Tue Jul 1 12:52:56 2008 +0100

    [util] Detect Mtools 3.9.10+ in genliso

    The genliso script requires Mtools 3.9.9+.  The version checking pattern
    does not support 3.9.10+ (the current release is 3.9.11).

    This patch updates the pattern to detect Mtools 3.9.10+.

src/util/genliso

index b8d9a11..12fee4e 100755 (executable)
@@ -21,7 +21,7 @@ case $# in
        ;;
 esac
 case "`mtools -V`" in
-Mtools\ version\ 3.9.9*|Mtools\ version\ 4.*)
+Mtools\ version\ 3.9.9*|Mtools\ version\ 3.9.[1-9][0-9]*|Mtools\ version\ 4.*)
        ;;
 *)
        echo Mtools version 3.9.9 or later is required